不可在公网路由的 IPv4 地址段
IPv4 地址空间中,有一部分地址段被 IANA 预留用于特殊用途,不能在互联网上直接路由。了解这些地址段,在网络规划和故障排查时都会用到。
下面按用途分类列出,排除多播(D 类,224.0.0.0/4)和预留(E 类,240.0.0.0/4)地址。
私有地址(RFC 1918)
这三个段是私有网络中最常见的:
10.0.0.0/8— 16,777,214 个地址172.16.0.0/12— 1,048,574 个地址192.168.0.0/16— 65,534 个地址
这些地址在互联网上不会被路由。如果在公网看到这些源地址的包,直接丢弃。
环回地址
127.0.0.0/8 — 全部指向本机。发往这个段的包由内核自己处理,不会离开主机。
链路本地地址(RFC 3927)
169.254.0.0/16 — 当设备无法从 DHCP 获取地址时,自动在这个段内选一个地址。只能在同一物理/逻辑链路上通信,不能跨路由器。
文档与测试地址(RFC 5737)
这三个段专门用于文档和示例,不应该出现在实际网络中:
192.0.2.0/24— TEST-NET-1198.51.100.0/24— TEST-NET-2203.0.113.0/24— TEST-NET-3
写教程、配置示例时用这些地址,不会和真实网络冲突。
运营商级 NAT(RFC 6598)
100.64.0.0/10 — 给运营商内部 CGN 设备用的共享地址空间。和 RFC 1918 的私有地址不同,这个段是专门给运营商网络用的。
基准测试(RFC 2544)
198.18.0.0/15 — 网络设备性能基准测试用的地址段。
IETF 协议分配(RFC 6890)
192.0.0.0/24 — IANA 保留给 IETF 协议专用的地址块。
其他
0.0.0.0/8 — 除了 0.0.0.0 本身表示本网络外,这个段的其他地址在互联网上不可路由。
这些地址段在路由器上通常不需要配置默认路由,因为它们本就不该出现在公网中。如果你在自己的网络里看到这些地址的路由条目,很可能是配置错误。